نمایش نتایج: از شماره 1 تا 1 , از مجموع 1

موضوع: کنترل پهنای باند در سیسکو – Cisco QOS

  1. #1
    RezaBehroozi admin آواتار ها
    تاریخ عضویت
    Jan 1970
    محل سکونت
    Iran/Shiraz
    نوشته ها
    11,167
    تشکرها / پسندها

    پیش فرض کنترل پهنای باند در سیسکو – Cisco QOS

    نگارنده : رضا بهروزی ( [فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید][فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید])

    کنترل پهنای باند در روتر های سیسکو شیوه های مختلفی دارد ،در این آموزش یکی از بهترین و ساده ترین روش ها را با ذکر چند نمونه توضیح خواهیم داد.

    نمونه ۱ :
    می خواهیم دانلود کاربر را به ۲ مگابیت در ثانیه محدود کنیم،فرض بر این است که کاربر sub interface مخصوص به خود را در روتر ما دارد.
    policy-map مربوط به پهنای باند ۲ مگابیت را ایجاد می کنیم و به کاربر اختصاص می دهیم.
    کد:
    policy-map 2M
    class class-default
    shape average 2048000
    ۲M نام Policy-map می باشد که هر نام دلخواهی می توانید برای ان انتخاب کنید،۲۰۴۸۰۰۰ هم میزان پهنای باند به بیت می باشد که شما آن را هم بسته به نیاز می توانید تغییر دهید.
    حال policy-map را روی اینترفیس کاربر تنظیم کنید:
    کد:
    interface GigabitEthernet0/1.801
    service-policy output ۲M
    نمونه ۲ :
    می خواهیم به یک مشتری بر روی یک اینترفیس دو نوع سرویس مختلف از قبیل اینترنت و اینترانت با پهنای باند متفاوت ارایه دهیم.این کار را با تفکیک ترافیک ها توسط access-list انجام می دهیم.
    به ازای هر سرویس یک access-list ایجاد کنید و آدرس IP های هر کدام را در ان مشخص کنید.
    نکته بسیار مهم :
    اگر به مشتری IP دهید و در access-list مشخص نکنید ،پهنای باند ان محدوده IP نامحدود خواهد بود.
    کد:
    access-list 188 permit ip any 10.58.8.36 0.0.0.3
    access-list 189 permit ip any 199.44.227.32 0.0.0.7
    access-list 189 permit ip any 168.228.202.128 0.0.0.63
    ایجاد class-map به ازای هر سرویس و مشخص کردن access-list مربوط به آن
    کد:
    class-map match-any Persianadmins-Internet
    match access-group 189
    class-map match-any Persianadmins-Intranet
    match access-group 188
    ایجاد policy-map و مشخص کردن پهنای باند هر سرویس
    کد:
    policy-map Persianadmins
    class Persianadmins-Internet
    shape average 97280000
    class Persianadmins-Intranet
    shape average 1024000
    اختصاص Policy-map به interface مربوط به کاربر
    کد:
    interface GigabitEthernet0/1.801
    service-policy output Persianadmins
    نمونه ۳ :
    چندین سرور در شبکه داریم و می خواهیم پهنای باند دانلود هر سرور را جداگانه تنظیم کنیم.همه سرورها در یک vlan هستند یا به یک اینترفیس روتر متصل اند.
    به ازای هر سرور یک access-list ایجاد و ادرس ip سرور را در آن مشخص می کنیم
    کد:
    access-list 185 permit ip any host 129.75.224.50
    access-list 186 permit ip any host 129.75.224.51
    ایجاد class-map به ازای هر سرور و مشخص کردن access-list مربوط به آن
    کد:
    class-map match-any Server1
    match access-group 185
    class-map match-any Server2
    match access-group 186
    ایجاد policy-map و مشخص کردن پهنای باند هر سرور
    کد:
    policy-map Servers
    class Server1
    shape average 2048000
    class Server2
    shape average 1024000
    اختصاص Policy-map به interface مربوط به سرورها
    کد:
    interface GigabitEthernet0/1.801
    service-policy output Servers
    نمونه ۴ :
    در این نمونه می خواهیم به کاربر در زمان های مختلف پهنای باند دانلود متفاوت اختصاص دهیم.فرضا زمان را به دو دسته شب و روز تقسیم می کنیم.
    ابتدا محدوده ی زمان هایی که می خواهیم پهنای باند متفاوت داشته باشیم را با استفاده از time-range ایجاد می کنیم.
    کد:
    time-range 7-14
    periodic daily 07:00 to 14:00
    time-range 14-24
    periodic daily 14:00 to 00:00
    time-range 24-7
    periodic daily 00:00 to 07:00
    سپس time-range های ایجاد شده را به access-list ها اختصاص می دهیم.در اینجا ما دو بازه زمانی روز و شب داریم،پس یک access-list برای روز و یکی برای شب ایجاد و زمان ها را برای این دو access-list مشخص میکنیم.
    کد:
    access-list 135 permit ip any any time-range 7-19
    access-list 136 permit ip any any time-range 24-7
    access-list 136 permit ip any any time-range 19-24
    ایجاد class-map به ازای هر بازه زمانی و مشخص کردن access-list مربوط به آن
    کد:
    class-map match-any Persianadmins-Day
    match access-group 135
    class-map match-any Persianadmins-Night
    match access-group 136
    ایجاد policy-map و مشخص کردن پهنای باند هر بازه زمانی
    کد:
    policy-map Persianadmins
    class Persianadmins-Day
    shape average 97280000
    class Persianadmins-Night
    shape average 1024000
    اختصاص Policy-map به interface مربوط به کاربر
    کد:
    interface GigabitEthernet0/1.801
    service-policy output Persianadmins
    نمونه ۵ :
    برای محدود کردن آپلود هم مشابه دانلود عمل می کنیم با این تفاوت که در تنظیمات policy در اینترفیس کاربر به جای output از input استفاده می کنیم و اگر از access-list استفاده میکنیم جای source و destination را تغییر می دهیم.در اپلود ادرس IP کاربر source access-list می باشد.همچنین در policy-map باید به جای shape از policy استفاده کنیم.
    ساخت policy-map
    کد:
    policy-map Upload
    class class-default
    police rate 1024000
    اختصاص به اینترفیس کاربر
    کد:
    interface GigabitEthernet0/1.801
    service-policy input Upload
    با تشکر – [فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید]
    [فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید]

  2. Thanks yashgin128 thanked for this post
    Likes manga liked this post
  3. # ADS
    Circuit advertisement
    تاریخ عضویت
    Always
    محل سکونت
    Advertising world
    نوشته ها
    Many
    مودم LTE بیرونی
     

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

موضوعات مشابه

  1. پاسخ ها: 0
    آخرين نوشته: 2010/03/23, 09:01 AM
  2. پاسخ ها: 0
    آخرين نوشته: 2009/09/17, 09:34 PM
  3. پاسخ ها: 0
    آخرين نوشته: 2007/04/14, 02:38 AM
  4. Hacking Exposed Cisco Networks, Cisco Security Secrets & Solutions
    توسط admin در انجمن امنیت
    پاسخ ها: 0
    آخرين نوشته: 2007/03/20, 04:53 PM
  5. پاسخ ها: 0
    آخرين نوشته: 2007/02/11, 03:45 AM

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •